DirtyEvo.com - The Evo and DSM Rally Forum!

Go Back   DirtyEvo.com - The Evo and DSM Rally Forum! > DirtyEvo Car Specific > Evo 1-9 > Exterior|Interior

Reply
 
Thread Tools Display Modes
  #1  
Old 03-21-2016, 02:39 PM
Caffeine Slug Caffeine Slug is offline
Dusty
 
Join Date: May 2012
Location: Tucson, AZ
Posts: 26
Name: Ben
Drives: 2005 Evo RS
Default Rear bumper damage

I've had a lot of issues with the rear bumper cover, where it attaches to the body on the passenger side. Is anyone else having these issues, and found a good solution?

The first few times, the attachment near the wheel well was pulling away from the body. I eventually took the car to a body shop and their repair looked great, now it's actually tearing the bumper cover itself.


My guess is that this is from all the dirt and mud hitting the mudflap, but I'm not sure. Looking for suggestions on how to deal with this.
Reply With Quote
  #2  
Old 05-14-2016, 11:28 PM
slowautoxr's Avatar
slowautoxr slowautoxr is offline
Filthy
 
Join Date: Nov 2012
Location: Decatur, AL
Posts: 218
Name: Charles
Drives: IX RS
Default

This happened to mine as well. I used to just tape it up prior to events. After I sold it, I found a solution that can probably be adapted to this. Check out the thread I wrote here.
__________________
Charles
'06 Evo RS <sold after winning 3 SCCA RX National Championships>
'00 2.5RS
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:29 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.